SDDC Manager でのアップグレードプリチェック や Lifecycle Manager での "User session count is limited to 550. Existing session count is 550 for user"
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SDDC Manager でのアップグレードプリチェック や Lifecycle Manager での "User session count is limited to 550. Existing session count is 550 for user"

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Article ID: 400453

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VMware Cloud Foundation VMware vCenter Server

Issue/Introduction

免責事項: これは英文の記事「User session count is limited to 550. Existing session count is 550 for user" during SDDC Manager upgrade precheck or Lifecycle Manager(327211)」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。

  • SDDC Manager のアップグレードのプリチェックが3%でハングし、1分後に失敗する。

    /var/log/vmware/vcf/lcm/lcm-debug.log
    YYYY-MM-DDT17:20:07.040+0000 ERROR [vcf_lcm,xxxxxxxxxxxxxx,3b2e] [c.v.e.s.l.a.i.i.HardwareSupportClientImpl,Scheduled-10] Exception occurred while loading the Hardware Support Info for the domain xxxxxxxxx-xxxx-xxxx-xxxxxxxxxx com.vmware.vapi.std.errors.ServiceUnavailable: ServiceUnavailable (com.vmware.vapi.std.errors.service_unavailable) => {     messages = [LocalizableMessage (com.vmware.vapi.std.localizable_message) => {     id = com.vmware.vapi.endpoint.failedToLoginMaxUserSessionCountReached,     defaultMessage = User session count is limited to 550. Existing session count is 550 for user [email protected].,     args = [550, 550, [email protected]],     params = <null>,     localized = <null> }],     data = <null>,     errorType = SERVICE_UNAVAILABLE
  • Lifecycle Manager に depot zip をインポートしようとすると、「予期しないエラーが発生しました 」というエラーメッセージが表示される
  •  /var/log/vmware/vsphere-ui/logs/vsphere_client_virgo.log
    com.vmware.vapi.std.errors.service.unavailable => {data=<unset>,error_type=SERVICE_UNAVAILABLE, messages=User session count is limited to 550. Existing session count is 550 for user <Username>., localized=<unset>, id=com.vmware.vapi.endpoint.failedToLoginMaxUserSessionCountReached,

Environment

VMware Cloud Foundation 4.x
VMware Cloud Foundation 5.x
VMware vCenter Server 7.0.x
VMware vCenter Server 8.0.x

Cause

この問題は、vCenter Serverでユーザーセッション数が上限に達した場合に発生します。

Resolution

Workaround 1:

Option 1

  • 影響を受けている vCenter を再起動

Option 2

  • 影響を受けている vCenter の session.maxSessionsPerUser の値を増やす
    1. vCenter の適切なスナップショットを取得します
    2. vCenter に root ユーザーで SSH 接続します
    3. /etc/vmware-vapi/endpoint.properties のバックアップを取得します

      cp /etc/vmware-vapi/endpoint.properties /etc/vmware-vapi/endpoint.properties.backup

    4. endpoint.properties ファイルを編集します

      vi /etc/vmware-vapi/endpoint.properties

    5. session.maxSessionsPerUser のコメントを削除して値を1000に増やす (注: このパラメータはvcenter 8.0.Xには存在しないため、手動で値を1000に設定する必要があります)

      #session.maxSessionCount=1000
      session.maxSessionsPerUser=1000
      # One hour is 3 600 000 millis
      #session.maxSessionIdleMilliseconds=3600000
      # One day is 86 400 000 millis
      #session.minSessionLifespanMilliseconds=86400000
      # Two days are 172 800 000 millis
      #session.maxSessionLifespanMilliseconds=172800000

    6. vmware-vapi-endpoint サービスを再起動します

      service-control --stop vmware-vapi-endpoint && service-control --start vmware-vapi-endpoint

Workaround 2:

Resolution - この問題は、infraprofile サービスが vAPI 要求に応答しないために発生します。
この問題は、将来の vCenter リリースで解決される予定です。

/var/log/vmware/vapi/endpoint/endpoint.log からアイドルタイムアウトを確認する。

キーワード: idle

YYYY-MM-DDT16:39:53.554Z | INFO | session-monitor1 | MasterSessionMonitor | Session [email protected] (internal id xxxxxxxx-xxxx-xxxx-xxxxxxxxx, token 3e252...) has been idle for 3,600,907 milliseconds.


以下を実行して、infraprofileサービスのメモリを増やす:


1.  infraprofile サービスに割り当てられている現在のメモリをチェックする :

cloudvm-ram-size -l | grep vmware-infraprofile

2. infraprofile サービスに割り当てられたメモリを 2 倍にする :

cloudvm-ram-size -C <DoubleOutputFromStep1> vmware-infraprofile

3. infraprofileサービスを再起動する:

service-control --stop vmware-infraprofile && service-control --start vmware-infraprofile

service-control --restart vmware-vapi-endpoint

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