After upgrading to Aria Operations 8.18.3, user rights are no longer functioning correctly.
Operations and Diagnostics views for example are no longer visible for administrators, which includes local and AD accounts that had the Administrator role before upgrade
VC users with Administrator level role in vCenter are not able to see Operations or Diagnostics views
Environment
Aria Operations 8.18.3
Cause
Before the upgrade, all content was exported from Administration > Control Panel > Content Management, which includes: Users, User Groups and User Roles.
Post upgrade, all content was imported back in.
When looking at the Role: Administrator, there may be many items unchecked. Specifically Operations Menu and Diagnostics.
Since these are new in Aria Operations 8.18.x, the older Administrator role that was imported from the pre-upgrade version did not include these along with many other permissions.
The cause for vCenter users not seeing the Operations menu is due to the reimport of all content from a previous version which did an overwrite to the built-in ContentAdmin, GeneralUser-* and PowerUserMinusRemediation roles
VC users by default are not able to see the Diagnostics menu. This has to be set within the roles noted above
These roles are mapped to the 'vCenter vRealize Operations Read Only Role' privileges set on the vCenter side
Resolution
To resolve AD and Local accounts:
Login to Aria Operations as an administrator or with the local admin account
Access the Administrator role from Control Panel > Access Control > Roles, click the ellipses (3 dots) and choose Edit
Ensure that Diagnostics and Operations > Operations Menu are selected along with any other permissions you need for your environment
Alternatively, check the box at the top for 'Select all Permissions'
Click Save
Logout any local or AD user session and login again to test to ensure the issues are now resolved
To resolve VC user accounts:
Login to Aria Operations as an administrator or with the local admin account
Access one or more of the roles below from Control Panel > Access Control > Roles, click the ellipses (3 dots) and choose Edit
ContentAdmin
GeneralUser-1
GeneralUser-2
GeneralUser-3
GeneralUser-4
PowerUserMinusRemediation
PowerUser
Ensure that Diagnostics and Operations > Operations Menu are selected along with any other permissions you need for your environment
Click Save
Logout any VC user session and login again to test to ensure the issues are now resolved