Users are facing a blank screen issue in Modern UX
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Article ID: 400365
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Updated On:
Products
Clarity PPM On Premise
Issue/Introduction
Clarity is integrated with ADFS for SSO authentication
A set of users use SP initiated flow to login to the application
Another set of users use the IdP initiated flow
This second set of users intermittently see a blank page when they land on the Modern UX
To enable landing on the MUX a double encoded URL is configured at ADFS
Refreshing multiple times results in the page getting loaded.
Environment
Clarity 16.1.2
Cause
The issue is not with authentication
From looking at the network traffic within the browser (Developer Tools > Network tab), it is evident that calls to pendo.io are blocked for those who are facing this issue
Since the second set of users mentioned above are present in a specific geographic location, network settings there seem to differ from other regions.
Resolution
Calls to pendo.io are removed from the application in the following versions / patches:
Clarity 16.3.1
Clarity 16.3.0 Patch 1 (16.3.0.1)
Clarity 16.2.3 Patch 3 (16.2.3.3)
An upgrade to one of these versions can be considered
Setting 'Send Usage Metrics (Services restart required on change)' flag in the NSA to False also prevents calls from being made to pendo.io.