Error "Some of the selected virtual machines are not in a valid state for replication." and "Already configured to" while configuring replication for a VM
book
Article ID: 400345
calendar_today
Updated On:
Products
VMware Live Recovery
Issue/Introduction
Symptoms:
When configuring the replication for the virtual machine from Prod to DR, the validation failed with the error "Some of the selected virtual machines are not in a valid state for replication."
When checking the replication status during the validation it says "Already configured to VM-Name"
On the vSphere replication configuration wizard, you will see the below validation error.
Environment
vSphere Replication 8.8
Cause
This issue would occur when the VM was enabled with replication from Prod to DR and the replication was broken or the VM was force stopped where the STALE entry was left on the replication servers.
When verifying the replication status for the VM on both the primary and DR site, you would see the status error as below.
Resolution
In order to resolve the issue we need to verify and remove the STALE entries from both Primary and DR site.
This error message might appear on the following occasions.
If, due to a connectivity issue or some other problem, an orphaned replication remains on one of the sites while it is deleted from the other site, the orphaned replication prevents you from configuring a new replication for the same virtual machine.
If you have paired two sites and reinstall the vSphere Replication Management server appliance, the other site contains information about the old appliance and database, and prevents you from configuring new replications.
If you have not reinstalled the vSphere Replication Management server, an orphaned replication exists in your environment. You can force stop this replication to delete it.
Log in to the vSphere Client. On the home page, click Site Recovery and click Open Site Recovery. On the Site Recovery home page, select the site pair which contains the protected site, mentioned in the error message that you received. Click the Replications tab and select a replication from Outgoing or Incoming. Click the Remove icon and select Force stop replication(s).