Error "Cloud Partner Navigator Test Failed due to "Http failure response for https://UM_FQDN/api/v1/run_uploader: 502 Bad Gateway".... " While sending update to CPN in Usage Meter
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Article ID: 400330
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Updated On:
Products
VMware Usage Meter
Issue/Introduction
Upon successful login to Usage Meter UI, a red banner message appears with the title: Unable to process request. Error: Unable to call service at https://localhost:8051/api/v2/journal: 500 - {"timestamp":"####-##-#####:MM:SS.299+00:00","status":500,"error":"Internal Server Error","path":"/api/v2/journal"}, body was class="highlightDomain">okhttp3.RequestBody$Companion$toRequestBody$2@7c821967
Navigate to Usage Meter UI > Settings > Send Update to Cloud Partner Navigator > Send update to CPN, fails with an error: Cloud Partner Navigator Test Failed due to "Http failure response for https://UM_FQDN/api/v1/run_uploader: 502 Bad Gateway". Please open a ticket with VMware support at https://my.vmware.com
Environment
VMware vCloud Usage Meter 4.8
Cause
This issue is caused by incorrect file ownership permissions for database files located in the following directory: /opt/vmware/cloudusagemetering/platform/data
To verify, run the following command on the Usage Meter appliance: ls -al /opt/vmware/cloudusagemetering/platform/data
usagemeter@test$ ls -al /opt/vmware/cloudusagemetering/platform/data total 312 -rw-r -- r -- 1 usagemeter usagemeter 192512 Aug 31 2024 journal-service.db -rw-r -- r -- 1 usagemeter usagemeter 110592 Feb 19 10:09 schedule-service.db
The files journal-service.db and schedule-service.db should be owned by their respective services (journal-service and schedule-service), but are currently owned by usagemeter.
Resolution
To resolve the issue
Change the ownership of journal-service.dband schedule-service.db: Run the following commands to change the ownership of the files to login-service: