Unable to ping the gateway from the ESXi host
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Unable to ping the gateway from the ESXi host

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Article ID: 400301

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

  • Problem with communication - host is down 
  • When testing an ESXi's host management network configuration via the DCUI, the ESXi host is unable to ping the default gateway and DNS servers:

Environment

VMware ESXi 7.x, 8.x

Cause

The network configuration is either inconsistent with the physical switch port configuration to which the ESXi host is connected, or the NICs are not in a connected/up status.

Resolution

  1. Check for any layer 1 issues such as cable issues are resolved (reseating cables, using approved optics, using approved cables, etc) from the ESXi host to the physical switches.

    1. Check the vmnic admin status and link status columns from the ESXi console by running:
      # esxcli network nic list
      Ensure both admin and link status are "Up".

  2. Check the layer 2 configuration of the physical switch to make sure that it is configured the same as the ESXi hosts (tagged/untagged, VLAN ID, MTU etc).
    1. Ensure the subnet mask for vmk0 is correct, and that the IP address assigned to vmk0 is in the subnet. 
    2. An easy test to check the Layer 2 connectivity is to ping vmk0 on another working host from the host that is down (vmkping -I vmk0 targetIP)

      Note : Refer to this link for configuration changes to a vSwitch / Portgroup via CLI.

  3. Check the layer 3 configuration of the ESXi host and the environment its located in. Common issues can include a typo of the IP address of the ESXi host, subnet mask or default gateway.

  4. Check with your physical switch vendor for assistance in checking the configuration of the physical switches.

Additional Information