VSS4004 "Cannot connect to TCP/IP system" error with PTC Implementer
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VSS4004 "Cannot connect to TCP/IP system" error with PTC Implementer

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Article ID: 400279

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Updated On:

Products

CA 2E

Issue/Introduction

He is unable to migrate a program from the test environment (on <server "B">) to the production environment (on <server "A") due to an error involving communication with a C-string. The return message he is receiving is: Opening ICF1.Error Encountered While Migrating Program to Production

He is using PTC Implementer to perform the migration.

Error message in the JOBLOG says:

Message ID: VSS4004
Message:  Cannot connect to TCP/IP system ##.##.##.##
Cause:    A connection cannot be established with remote system ##.##.##.## on port 30005
Recovery: Verify that the communications daemon is running on remote system ##.##.##.## using port 30005 and regular TCP/IP connections can be made (use PING utility). If further attempts fail, contact your system administrator for assistance.

We confirmed in the hosts file that the <server "A"> and <server "B"> both were configured with the correct IP address, and can successfully ping each other by IP address and receive a response.

This looks like a problem with the PTC Implementer code promotion utility and the host (<server "B">) is not communicating with the receiver (<server "A">). The IMCOM subsystem is active on <server "A"> and job ###### is listening on port 30005 for incoming connections. 

Environment

2E on IBMi platform
Issue was encountered using version 8.6 but suspect the same might arise with other versions

Cause

Using netstat, we discovered that the request from <server "B"> was not going to <server "A"> but was, instead going to an IP address of a server that doesn't exist anymore.

The IP address belonged to a web server which had been decommissioned.

Looking at the TCP/IP network configuration on <server "B">, in the "Change TCP/IP Domain" screen, at the Domain search list, we found a domain that no longer exists was included in that list.  

Resolution

In the TCP/IP network configuration we removed the obsolete domain from the Domain search list and now <server "A"> and <server "B"> can communicate successfully.

Additional Information

There is an article on the PTC website relating to the error seen in the JOBLOG.  Here is the link to the same: Implementer error VSS4004 as fails to resolve IP address before trying to Communicate to a Remote using TCP/IP lookup

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