Missing AM Inventory data on Linux Agent
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Missing AM Inventory data on Linux Agent

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Article ID: 400178

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Updated On:

Products

CA Client Automation CA Client Automation - IT Client Manager

Issue/Introduction

For some Linux Agents, some inventory data are missing or with N/A value.
Example below, values for Type, Model and Vendor are N/A

Environment

Client Automation - 14.5

Cause

This problem occurs if SMBIOS on the Linux machine is version 3.x
This could be checked with command :

dmidecode | grep '^SMBIOS'

Resolution

If SMBIOS has version 3.x then fixes T55V232 and T437424 should be installed on the Linux machine.
Open a case at CA Broadcom technical support and ask for the 2 fixes T55V232 and T437424

Installation order is important : install first the fix T55V232 and after T437424 

applyptf tool could be used to install the fixes or installation could be done manually with this method :

1- Stop caf
caf stop

2- Rename the files 

/opt/CA/DSM/Agent/AM/plugin/amhwinvux as amhwinvux.ori
/opt/CA/DSM/Agent/AM/plugin/caf/bin/cfbasichwux as cfbasichwux.ori
/opt/CA/DSM/caf/lib/libcainf.so as libcainf.so.ori

3- Copy the files 
Copy the file amhwinvux from fix T55V232 into /opt/CA/DSM/Agent/AM/plugin/
Copy the file cfbasichwux from fix T55V232 into /opt/CA/DSM/Agent/AM/plugin/caf/bin
Copy the file libcainf.so from fix T437424 into /opt/CA/DSM/caf/lib/

4- Start caf

5- Execute this to do a full AM inventory
caf start amagent args --rescan_inventory --collect

 

Additional Information

Information about these 2 fixes could be found in these articles :

Wrong System Serial Number on Linux Agent
NRI Agent crash with segmentation fault and error 139