VMware Cloud Service Provider (VCSP) License Key Generation Fails with 'Quantity cannot exceed [N] in the Consumption Portal
search cancel

VMware Cloud Service Provider (VCSP) License Key Generation Fails with 'Quantity cannot exceed [N] in the Consumption Portal

book

Article ID: 400169

calendar_today

Updated On:

Products

Issue/Introduction

As a VCSP (VMware Cloud Services Provider) partner attempting to generate new license keys within the Consumption Portal for a specific product/serial, you encounter the error message: "Quantity cannot exceed '[N]'." This prevents the successful generation of additional distinct license keys for that product/serial.

Environment

Consumption portal

Cause

This error occurs because the quantity of licenses you are attempting to generate for that specific product/serial exceeds the remaining allowance on your current commit contract. The number [N] (as shown in the error message) represents the exact maximum quantity of licenses that can still be generated for that product/serial.

Resolution

To resolve this issue and generate additional license keys:

  • Obtain a New Consumption Commit Contract:
    • Contact your sales person/ Account Manager for a new consumption contract to increase your available license quantity.
    • Once the new contract is active, you can generate additional keys in the Consumption Portal against the allowance from this new contract.