System user deleted report schedules
search cancel

System user deleted report schedules

book

Article ID: 400128

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

Existing report schedules were deleted by system user.  No new reports are being received.

Environment

VMware Aria Operations 8.x

Cause

The configured user that associated with the report schedules was deleted.  Once a user is deleted, this user is moved to an orphaned state.  The associated report schedules and dashboards will continue to operate normally.  When this user hits the defined retention period of 100 days, as configured in the System setting of the Global Setting, this user will be deleted from Aria Operations completely.

The following log excerpts provide the details on the user removal along with the cleanup of the report schedules.

/storage/log/vcops/log/analytics.audit-xxxxx-xxxx.xxxx.xxxx.xxxx.log

####-##-#####:59:49,510+0000 - UserId : ########-####-####-####-############, UserName : system, AuthSource : n/a, Session : n/a, ClientIP : n/a, Category : USER_REMOVE_ARCHIVED - Removing archived user(s) succeeded. ID(s): [#####-#######-#######-#########]


####-##-#####:59:49,516+0000 - UserId : ########-####-####-####-############, UserName : system, AuthSource : n/a, Session : n/a, ClientIP : n/a, Category : REPORT_SCHEDULE_DELETE - Deleting report schedule(s) succeeded. ID(s): [#####-#####-#####-#####-#####]

 

 

Resolution

Since the archived user has been removed, all the associated report schedules are also removed.  There is no recovery on the deleted user and schedules.

You can recreate the schedules with an admin user to prevent this issue from happening again.  The following reference provides the steps to schedule a report:  Schedule a Report