Compute Manager constantly showing a "Connection Status" of "Connecting"
search cancel

Compute Manager constantly showing a "Connection Status" of "Connecting"

book

Article ID: 399982

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

When viewing the Compute Manager (vCenter) inventory in the NSX Manager UI, the "Connection Status" of a Compute Manager is showing a status of "Connecting" but never fully connecting or failing.

The cm-inventory.log file is not generating or updating on at least one NSX Manager node in the cluster.

Environment

NSX 3.1.1

Cause

The cm-inventory service on at least one NSX manager is not fully running.

Resolution

Restart the cm-inventory service via CLI on all three Manager nodes using the below command and reassess the connectivity to the Compute Manager.

/etc/init.d/cm-inventory restart

Note: This command should be non-impactful but it is recommended to do so during a maintenance window, especially if multiple Compute Managers are connected in the environment, to reduce the potential risk.