Telegraf installation failed on UI immediately with unknown error
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Telegraf installation failed on UI immediately with unknown error

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Article ID: 399974

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

When trying to install the Telegraf Agent on Aria Operations UI, the process failed immediately with an unknown error.

Environment

VMware Aria Operations 8.x

Cause

DNS issue found on Cloud Proxy.  

A "124" response was received when performing the following command on the Cloud Proxies to inspect the timeout response to the vCenter.

  • "timeout 5 bash -c "</dev/tcp/vCenter_FQDN/443".
  • "echo $?

Result:  124

The "124" resulted from a connection that exceeded the 5 request attempting to the vCenter FQDN.

Note:  A response of "0" if the connection attempt is successful within the configured threshold.



Performed a DNS query on the FQDN resulted with timed out error.

One or more of the configured DNS server is not responding.

 

Resolution

  • Login to vCenter
  • Shutdown the Cloud Proxies VM.
  • Go to "Configure" Tab.  Go to "vApp Options".
  • Select "Domain Name Servers" setting, then click "Set Value".
  • Edit and update the correct DNS server entries.

Once DNS is updated, power up the Cloud Proxies.

SSH into the Cloud Proxies and ensure nslookup to the vCenter response with a valid result.