"Search index is out of sync" error when searching in NSX Federation Manager UI
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"Search index is out of sync" error when searching in NSX Federation Manager UI

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Article ID: 399906

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Updated On:

Products

VMware NSX

Issue/Introduction

  • Following an upgrade from NSX 3.x to NSX 4.x, the NSX UI's Alarm page is no longer loading.

  • The following message is displayed when attempting to reach the NSX Alarm page:

    Error: Search index is out of sync for 'IP Set, MACSet, NSGroup'. Run the 'start search resync all' CLI command on the NSX appliance to resync. If the issue persists, contact VMware Support. (Error code: 60516)

  • In the VMware NSX Search Manager logs (/var/log/search/search-manager.log) the following errors can be seen, please note that the number of batch items (groups) that may have the problem 

    2025-05-21T08:10:47.462Z INFO UfoIndexer-search_manager-0 UfoIndexer 5396 - [nsx@6876 comp="nsx-manager" level="INFO" subcomp="manager"] [Indexing] 1 chunks are created out of 72 batch items
    2025-05-21T08:10:47.505Z ERROR UfoIndexer-BatchExecutor-search_manager-3 UfoGenericConverter 5396 - [nsx@6876 comp="nsx-manager" errorCode="MP60511" level="ERROR" subcomp="manager"] [Indexing: DataProvider] Could not convert UFO object to Dto UfoObject{operationType=CREATE, descriptor=IndexingTypeDescriptor{tableName='InternalGroup', streamTag=MANAGER}, identifier=uuid {
      left:######################
      right:######################
    }
    [..]
    java.lang.reflect.InvocationTargetException: null
    Caused by: java.lang.IllegalArgumentException: No enum constant com.vmware.nsx.management.policy.policyframework.model.GroupMemberType.INVALID

Environment

VMware NSX Federation

Cause

The static member list is having an empty entry while the intent "Group" table was having group definition with segment path. Due to this, internal conversion of framework data was failing as empty member is invalid, which in turn is impacting search indexing and the UI.

Resolution

If you believe you have encountered this issue, please open a support case with Broadcom Support and refer to this KB article.
For more information, see Creating and managing Broadcom support cases.

Additional Information

If you are contacting Broadcom support about this issue, please provide the following:

 As root on the NSX Global Manager run the below corfu commands :

/opt/vmware/bin/corfu_tool_runner.py -n nsx --port 9000 -o showTable -t Domain >/image/gm_domain.txt
/opt/vmware/bin/corfu_tool_runner.py -n nsx --port 9000 -o showTable -t Span >/image/gm_Span.txt
/opt/vmware/bin/corfu_tool_runner.py -n nsx --port 9000 -o showTable -t Segment >/image/gm_segment.txt
/opt/vmware/bin/corfu_tool_runner.py -n nsx --port 9000 -o showTable -t Group >/image/gm_group.txt
/opt/vmware/bin/corfu_tool_runner.py -n nsx --port 9000 -o showTable -t ReferenceObject >/image/gm_ReferenceObject.txt
/opt/vmware/bin/corfu_tool_runner.py -n nsx --port 9000 -o showTable -t Site >/image/gm_site.txt
/opt/vmware/bin/corfu_tool_runner.py -t Segment -n nsx -o showTable >/image/Segment.txt
/opt/vmware/bin/corfu_tool_runner.py -t LogicalSwitch -n nsx -o showTable >/image/LogicalSwitch.txt
/opt/vmware/bin/corfu_tool_runner.py -t GenericPolicyRealizedResource -n nsx -o showTable >/image/gprr.txt
/opt/vmware/bin/corfu_tool_runner.py -t InternalGroup -n nsx -o showTable >/image/InternalGroup.txt

Please also collect responses of below API's:

https://{{nsx_mgr_ip}}/api/v1/ns-groups
https://{{nsx_mgr_ip}/api/v1/logical-switches  

Please see below kb's for generating NSX logs bundles for offline review with Broadcom support