HCX Migrations failing with error "No version for VMODL calls"
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HCX Migrations failing with error "No version for VMODL calls"

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Article ID: 399899

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Updated On:

Products

VMware HCX

Issue/Introduction

  • HCX migrations are failing with the following error:
    A general system error occurred: No version for VMODL calls to <<last binding: <<TCP '127.0.0.1 : 43600'>, <TCP '127.0.0.1 : 1080'>> >, /pbm/sdk>

Environment

HCX
vCenter Server

Cause

This issue occurs when the Profile-Driven Storage service in vCenter is either not running as expected or has been stopped.

Resolution

  • To resolve this issue, restart the Profile-driven storage service on the vCenter.
  • Below commands can be used on vCSA SSH to stop/start/check status of sps service.
    service-control --status vmware-sps
    service-control --stop vmware-sps
    service-control --start vmware-sps


  • If you believe you are experiencing this issue and Profile-driven storage service(vmware-sps) service on vCenter Server does not start, please open a support case with vCenter Team (Broadcom Support) and refer to this KB article.
    For more information, see Creating and managing Broadcom support cases.

Additional Information