Unable to access Dev and Test environments
search cancel

Unable to access Dev and Test environments

book

Article ID: 399881

calendar_today

Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

  • There are two non-produciton environments - Dev and Test
  • Both these are SSO enabled
  • A specific user cannot login to these non-production environments
  • It is possible to access the Production environment for the same user
  • Other users do not have any issues with accessing the non-production and production systems.

Cause

When this non-production URL, on which Clarity is hosted, is accessed in a web browser, since the system is SSO enabled, it redirects to the customer Identity Provider for authentication. This is apparent from looking at the URLs that get loaded in the browser.

The Identity Provider then challenges the user, and asks for username and password. Once the credentials are provided, the Identity Provider does not redirect back to the Clarity system.

Instead, an error page is displayed. This error page has the same URL as that of the customer Identity Provider.

Resolution

Issue has to be looked into at the customer IdP. Logs etc. of that IdP can be referenced to understand the exact issue.