Powering on VM Fails with PBM Error
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Powering on VM Fails with PBM Error

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Article ID: 399812

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

When attempting to power on a VM, a general system error occurs with a PBM error message:

"A general system error occurred: PBM error occurred during PreReconfigureCallback: Fault cause: pbm.fault.PBMFault ; Error when trying to run pre-provision validation; Invalid entity"

Cause

The issue is caused by an invalid VM configuration referencing a decommissioned disk. 

  •  The VM's disks point to inaccessible datastores.
  •  One or more VMDKs are associated with non-existent or inaccessible storage.

Resolution

  1. Identify inaccessible datastores: Determine which datastores are inaccessible and decommissioned.
  2. Locate the VMX file: Find the VMX file associated with the affected VM.
  3. Make a backup copy of the .vmx file: Make a backup copy of the .vmx file. If the edits break the virtual machine, rolling back to the original version of the file is an option.
  4. Modify the VMX file: Use the vi command to edit the VMX file and remove references to the decommissioned disk(s) by commenting out (hashing out) the associated VMDK entries.
  5. Save changes: Save the updated VMX file. wq!
  6. Reload the VM: Run the following command to Reload the VMX file without removing the virtual machine from inventory: vim-cmd vmsvc/reload <VM_ID>
  7. Power on the VM: After making the changes, attempt to power on the VM. The remaining disks should become accessible.

Additional Information

Before decommissioning a datastore, ensure that:

  • All disks associated with the datastore are detached from VMs.
  • No VMs are referencing the datastore.