NO SAN reported for the Solution User certificates within vCenter
search cancel

NO SAN reported for the Solution User certificates within vCenter

book

Article ID: 399771

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

When validating the certificates in use for vCenter you may see an error / warning regarding NO SAN for the solution user certificates.  

 

Checking Solution User certificates: 
  machine                       NO SAN
  vsphere-webclient             NO SAN
  vpxd                          NO SAN
  vpxd-extension                NO SAN
  hvc                           NO SAN

Environment

vCenter Server 7.x

vCenter Server 8.x

Cause

This issue is due to a missing Subject Alternative Name in the certificates used by the Solution Users.  

Resolution

To resolve this, refresh the Solution User certificates and ensure they include a valid Subject Alternative Name for the target vCenter Server.  This can be accomplished by leveraging the vCert utility or Certificate Manager.

For vCert, please see the following documentation: vCert - expired certificate replacement script

For Certificate Manager, please see the following documentation: Using vSphere Certificate Manager to Replace SSL Certificates