Identity Manager r12.x - Logoff URL Value for Identity Manager Web Agent.

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Article ID: 3997

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Updated On:

Products

DIRECTORY CA Identity Manager CA Identity Governance CA Identity Portal CA Risk Analytics CA Secure Cloud SaaS - Arcot A-OK (WebFort) CLOUDMINDER ADVANCED AUTHENTICATION CA Secure Cloud SaaS - Advanced Authentication CA Secure Cloud SaaS - Identity Management CA Secure Cloud SaaS - Single Sign On SECURITY MISC CODES SINGLE SIGN ON - LEGACY CA Data Protection (DataMinder) CA User Activity Reporting

Issue/Introduction

When setting up the logout conditions for the Identity Manager Web agent, within the agent configuration object in Site Minder, you have added the LogoffURL path value which corresponds to an html file located on the Identity Manager server.

When the logoff from Identity Manager has been attempted, you are presented with the login page which forces you to log in again, after having logged out (you are able to test this when you return to the Identity Manager URL).

However, after doing this once, if you try logging out again, and then attempt to access the Identity Manager URL after the second logout, you are able to get back into Identity Manager as though no logout has taken place.

The logout works fine the first time, but doesn't seem to be recognized after that.

Cause

The browser is caching the logoff html page, so the second time you hit the page it is served from the browsers cache and it never hits the web server and so never hits the web agent. If the agent never sees the request, then it can't delete the cookie.

Environment

Identity Manager R12.x

Resolution

The fix for this is in the logoff html page. You must put in Meta tags to prevent the browser from caching the page.

Please review the following webpage, specifically the section titled: "HTTP-EQUIV META Tags"
http://support.microsoft.co m/kb/234067.

The code that is in that section needs to be put into the html code of your logoff page.