Pricebook not applying, no account assignment
search cancel

Pricebook not applying, no account assignment

book

Article ID: 399651

calendar_today

Updated On:

Products

CloudHealth

Issue/Introduction

A custom Pricebook has been created for a customer but is not reflecting in reporting data. When checking the Pricebook assignment for the customer, there is a "There are no price book account assignments" notification:

Cause

This is caused by missing the account assignment step in Pricebook configuration

Resolution

  1. Get the price_book_assignment_id from the Get All Price Book Customer Assignments REST API endpoint.
  2. Use the previous ID in the Assign Price Book to Account REST API call to assign the pricebook to a set of customer accounts

Additional Information

See the following KB for all steps to configure a Custom Pricebook: Steps to create Custom Price Book