Spectrum OneClick Single Sign-On Configuration page SAML options not displayed
search cancel

Spectrum OneClick Single Sign-On Configuration page SAML options not displayed

book

Article ID: 399605

calendar_today

Updated On:

Products

Network Observability Spectrum

Issue/Introduction

SAML Option Not Showing

Tried configuring Spectrum SSO for SAML in the OneClick Administration page. It didn't work but we're not able to modify the configuration. Going to Administration -> Single Sign-On Configuration in the OneClick admin site doesn't work. It shows all options but selecting SAML returns a blank screen. No configuration information is presented.

The following error is seen in the OneClick $SPECROOT/tomcat/log/catalina.out (stdout.log on Windows) shows the following error when attempting to access the SAML configuration page.

 

2025-05-30 09:54:41,346 [https-jsse-nio-8443-exec-38] INFO  org.apache.struts2.dispatcher.Dispatcher - Unable to find 'struts.multipart.saveDir' property setting. Defaulting to javax.servlet.context.tempdir
2025-05-30 09:54:42,437 [https-jsse-nio-8443-exec-38] ERROR org.apache.struts2.dispatcher.DefaultDispatcherErrorHandler - Exception occurred during processing request: java.io.IOException: An exception occurred processing [/WEB-INF/sso/sso-saml-config.jsp] at line [42]
39:         if (formBean == null) {
40:             formBean = new SSOConfigForm();
41:         }
42:         SamlUtils.initSSOConfigForm(formBean, request);
43:     } catch (JAXBException | ConfigurationException e) {
44:         e.printStackTrace();
45:     }

Stacktrace:
java.io.IOException: java.io.IOException: An exception occurred processing [/WEB-INF/sso/sso-saml-config.jsp] at line [42]

39:         if (formBean == null) {
40:             formBean = new SSOConfigForm();
41:         }
42:         SamlUtils.initSSOConfigForm(formBean, request);
43:     } catch (JAXBException | ConfigurationException e) {
44:         e.printStackTrace();
45:     }

Stacktrace:
...
Caused by: java.io.IOException: An exception occurred processing [/WEB-INF/sso/sso-saml-config.jsp] at line [42]

39:         if (formBean == null) {
40:             formBean = new SSOConfigForm();
41:         }
42:         SamlUtils.initSSOConfigForm(formBean, request);
43:     } catch (JAXBException | ConfigurationException e) {
44:         e.printStackTrace();
45:     }
Stacktrace:
...
Caused by: java.net.MalformedURLException: no protocol: /https://<SAML_IDP_HOST>/pf/federation_metadata.ping?PartnerSpId=/spectrum
...
2025-05-30 09:54:42,440 [https-jsse-nio-8443-exec-38] WARN  org.apache.struts2.dispatcher.DefaultDispatcherErrorHandler - Unable to send error response, code: 500; isCommited: true;
java.lang.IllegalStateException: Cannot call sendError() after the response has been committed
...

 

Environment

All supported Network Observability DX NetOps Spectrum releases

Cause

Bad config, or problems saving the config when attempting initial configuration resulted in broken SAML configuration that prevent the UI from loading.

Resolution

To resolve this issue take the following steps.

  1. Edit the saml.properties file.
    1. Remove the values from the entries with non-default values.
      • Ensure IdpMetadataLocation and Axis2IdpMetadataLocation fields have no values set as seen in the below image.
    2. The file should look like this when it's not been configured.
    3. Save the changes to the file.
  2. Stop tomcat.
  3. Delete the $SPECROOT/tomcat/work directory.
    • ONLY remove the work directory and it's contents.
  4. Start tomcat.