No users are able to authenticate as users / groups are not able to sync In VMware Indentity manager/vIDM
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No users are able to authenticate as users / groups are not able to sync In VMware Indentity manager/vIDM

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Article ID: 399541

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

  • None of the users/groups can sync, due to this,  VCF it's unable to complete the authentication to finish its deployment.
  • The exception below is under /opt/vmware/horizon/workspace/logs/connector.log on vIDM node:

2025-05-30T09:47:54,796 ERROR (pool-3336-thread-1) [;;;] com.vmware.horizon.connector.admin.controller.DirectoryController - Error occurred while verifying the Directory configuration.
com.vmware.horizon.connector.exception.ConfigurationVerificationException: Unable to bind to the directory
********
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Caused by: javax.net.ssl.SSLHandshakeException

Environment

VMware Identity Manager / vIDM 3.3.7

Cause

The javax.net.ssl.SSLHandshakeException error occurs in the context of VIDM (VMware Identity Manager) encryption, typically arising from issues with SSL/TLS certificates and trust. This error means the client and server cannot agree on secure encryption settings during the handshake.

Resolution