Loading transport case throws error persistence failed, error code 9
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Loading transport case throws error persistence failed, error code 9

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Article ID: 399470

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Updated On:

Products

Automic SaaS

Issue/Introduction

When attempting to load a transport case into an Automic SaaS system using a curl command, a response is given like:

PS C:\Users\automic> curl 'https://rest-endpoint.example.com/ae/api/v1/0100/transportcase' --header 'Content-Type: text/plain' --data-binary '@C:\automic\Utility\db\uc_data.txt' --cacert 'C:\automic\certsoot.crt' -u 'automic/automic:********'
{
  "error_code" : 8230190,
  "error" : "persistence failed",
  "objects" : [ {
    "name" : "UC_UTILITY_REORG",
    "error_code" : 9,
    "errors" : [ "invalid transport case" ]
  } ]
}

It could also show UC_UTILITY_ARCHIVE as the problem.

When attempting to load the AWI using Transfer -> Import and loading the transport case, the following errors pop up:

U08230190: persistence failed
U09 'UC_UTILITY_REORG': Access denied: UC_UTILITY_REORG

 

The transport case contains UC_UTILITY_ARCHIVE and/or UC_UTILITY_REORG

Environment

Automic SaaS

Cause

As a part of Automic maintenance, a user is placed into a client within 24 hours of creation called UTL/*.  UC_UTILITY_ARCHIVE and UC_UTILITY_REORG are also created and object level authorization (OACL) is put on these objects for security purposes.  This causes a problem when loading the transport case as there is no function to ignore objects with OACL entries.

Resolution

A future version of Automic will include the ability to have the REST API ignore objects with OACL entries.  For now, a workaround must be used:  

  1. In the client being unloaded, go to the <No Folder> (or do a system search) and rename the UC_UTILITY_* variables to some other name
  2. Unload the client
  3. Load the transport case via REST API or the AWI