Cannot backup the database - table lock error
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Cannot backup the database - table lock error

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Article ID: 399370

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Updated On:

Products

Messaging Gateway

Issue/Introduction

While attempting to back up the Symantec Messaging Gateway (SMG) configuration, the following error is encountered:

Cannot backup the database.
ERROR: Failed to run: /opt/Symantec/Brightmail/mysql/bin/mysqldump;: 
mysqldump: Got error 144: "Table './brightmail/report_rcpt' is marked as crashed and last (automatic?) repair failed" when using LOCK TABLES

Cause

The error indicates that the report_rcpt table in the Brightmail MySQL database is marked as crashed, and previous automatic repair attempts have failed. 

Resolution

Run a Database check and repair to fix the issue.

    1. Login to the command line interface (CLI) on the Control Center as the "admin" account.
       
    2. Enter the following command.
      cc-config database --check 
       
    3. When prompted, enter yes to proceed.
       
    4. After the MySQL check has completed: if one or more MySQL tables are marked as crashed, entering the following command at the next CLI prompt will attempt to repair those tables.
      cc-config database --repair