Workload Automation Agent for PeopleSoft (plugin) failed to start

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Article ID: 3993

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Updated On:

Products

CA Workload Automation Agents

Issue/Introduction

Workload Automation Agent for PeopleSoft (plugin) failed to start with following error in the Agent's peoplesoft.log file:

 

 

Connection authorization failure occurred.

 

Reason: User ID or Password invalid. ERRORCODE=-4214, SQLSTATE=28000

 

 

 

 

Cause

As per the error message, the reason for the Connection authorization failure is;

Reason: User ID or Password invalid. ERRORCODE=-4214, SQLSTATE=280000

The User ID or Password used to connect to the PeopleSoft database is either invalid or expired.

 

Environment

Workload Automation Agent for PeopleSoft (plugin) on UNIX, Linux and Windows

Resolution

You can fix the invalid PeopleSoft user/password account issue by checking with the PeopleSoft Administrator on a valid user/password account to connect to the PeopleSoft database and follow these steps to change the default user/password account information:

Step 1: Encrypt the database password

  1. Change to the directory where System Agent and the PeopleSoft plug-in are installed.

  2. Run the password.sh (UNIX) file or the password.bat (Windows) file.

  3. At the prompt, enter your password.

The program will respond with the encrypted password.

Step 2: Modify the agentparm.txt file

  1. Stop System Agent.

  2. Open the agentparm.txt file.

  3. Specify the database user ID in the ps.db.accessId parameter. For example, ps.db.accessId=sysadm

  4. Specify the encrypted password in the ps.db.accessPassword parameter. For example, ps.db.accessPassword=6343B940CFCBC53E

  5. Save and close the agentparm.txt file.

  6. Start System Agent.

The corrected user account/password should allow the PeopleSoft Agent a successful login into the PeopleSoft database and the Agent start successfully.

Additional Information

CA Workload Automation Agent for PeopleSoft - 11.3 Troubleshooting

Failed to Connect to PeopleSoft Database

Valid on UNIX, Linux, and Windows

Symptom:

When I start the agent, it fails to connect to PeopleSoft. The following error message appears in the peoplesoft.log:

cybermation.plugins.ps.PsConfigException: Failed to connect to PS DB

Solution:

The PeopleSoft database connection parameters are not set correctly.

Follow these steps:

  1. Stop the agent.
  2. Open the agentparm.txt file.
  3. Review the following parameters and make corrections as required:
    • ps.db.accessId
    • ps.db.accessPassword
    • ps.db.url
  4. Save your changes.
  5. Start the agent.