Failure in DSM Upgrade from v2.2.X to v9.0 when "pg_stat_archiver" table is emply
search cancel

Failure in DSM Upgrade from v2.2.X to v9.0 when "pg_stat_archiver" table is emply

book

Article ID: 399265

calendar_today

Updated On:

Products

VMware Data Services Manager

Issue/Introduction

DSM Upgrade to v9.0 fails due to failure in provider backup.


To confirm this issue check this log:  "/var/log/tdm/provider/updatemanager.log"  for the line:

"Error generating upgrade marker file" 

Environment

VMware Data Service Manager 2.2.X

Cause

This issue is caused when "pg_stat_archiver" table is empty, to confirm this is the case: 

ssh to Provider vm either using putty or from the terminal:

ssh root@<proivder-ip>

Then execute:

psql vmware postgres;

Followed by: 

select * from pg_stat_archiver;

    * pg_stat_archiver does not have a valid record

Resolution

To resolve this issue please contact VMware support and quote this KB.