Virtual machine performance charts remain stuck in the loading state in the vSphere Client.
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Virtual machine performance charts remain stuck in the loading state in the vSphere Client.

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Article ID: 399214

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

After upgraded to ESXi 7.0 U3, the performance chart for the virtual machine stuck in the "Loading" state in the vSphere Client.

The file /var/log/vmware/vsphere-ui/logs/vsphere_client_virgo.log contains entries similar to the following:

[YYYY-mm-ddTHH:MM:SS.xxx] [INFO ] data-service-pool-775        70325324 129936 200285 c.v.o.c.advperfcharts.impl.PerformanceCountersPropertyProvider    Performance counters requested for object ManagedObjectReference: type = VirtualMachine, value = vm-XXXXX, serverGuid = YYYYYYYY-YYYY-YYYY-YYYY-YYYYYYYYYY
[YYYY-mm-ddTHH:MM:SS.xxx] [WARN ] data-service-pool-775        70325324 129936 200285 c.v.opsmgmt.client.advperfcharts.util.PerformanceCounterCache     Could not get all missing counter IDs!

Environment

ESXi  7.0 U3

vCenter versions below 7.0 U3

Cause

A new performance counter (mem.needed) for virtual machines was added in ESXi 7.0 U3, but vCenter Server versions below 7.0 U3 cannot manage this counter properly.

Resolution

Upgrade to vCenter 7.0 U3 or later.
vCenter 7.0 U3 and higher versions can properly handle this performance counter.
There is no workaround available.