Device present in Proxy Domain generate SNMP_NotResponding alert, but not primary
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Device present in Proxy Domain generate SNMP_NotResponding alert, but not primary

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Article ID: 399207

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Device 1 is present in 2 AMPM domains, discovered in one domain as primary and in another domain as proxy. Though the SNMP ReadOnly is same for both domains, proxy device generated a SNMP Agent not responding alarm, but not primary device.

Environment

Smarts - 10.1.x

Cause

It is seen that during polling cycles the domain that generated SNMP Agent not responding is polling the impacted device using both old and updated community string. This can be verified by capturing tcpdump and domain SNMP trace logs for 2-3 poll cycles. PFB commands to capture the same:

tcpdump:

tcpdump -i any host <device_ip> and port 161 -w tcpdump.pcap

trace log:

dmctl -s <IP_Domain> invoke ICIP_SNMPAccessorInterface::DEVSTAT-SNMP-Poller setTrace ICIM_UnitaryComputerSystem::<device> TRUE

Resolution

  • Restart IP domain manager. Post which SNMP Agent not responding alarm might still exist in SAM in SUSPENDED state. 
  • SUSPENDED state indicates that the Global Manager is no longer able to retrieve information about an active notification. When an underlying Domain Manager is not able to get to the source of a notification, it suspends the notification. The Domain Manager sends this message to the Global Manager, which in turn suspends the notification. A Domain Manager may not be able to get to the source of a notification because an SNMP agent is not responding or because it received unexpected error values in an SNMP request. This is expected behavior in Smarts and you can archive SUSPENDED notifications manually in bulk using a script. Kindly raise a case with Broadcom support if you continue to see anomaly in the community string used by Smarts to poll the devices.