Portal not working after certificate change
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Portal not working after certificate change

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Article ID: 399205

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Updated On:

Products

Network Observability

Issue/Introduction

1). Getting "This page isn't working." "500. That's an error." page while accessing portal post renewing certificate. PFB screenshot:

 

 

 

2). SslConfig health check results are successful:

============= Health Check Results =============
All tests of the Single Sign On module succeeded.
All tests of the DX NetOps Portal Console module succeeded.
All tests of the Event Manager module succeeded.
All tests of the Device Manager module succeeded.

Environment

All supported DX NetOps Performance Management releases

Cause

You used to connect using FQDNS (any of CN or SAN). But internal SSO config has IP address in config files. While IP address is covered by certificate, login to portal and SSO works. This issue is seen if you couldn’t add IP address to certificate request. Below exception is seen in the portal sso wrapper log:

WARN :oejes.ServletChannel:qtp21860102-31: handleException /sso/sign-in.jsp javax.net.ssl.SSLHandshakeException: No subject alternative names matching IP address ##.##.##.## found

Resolution

Run SsoConfig using tool /opt/CA/PerformanceCenter/SsoConfig to replace IP addresses with FQDN by selecting below options. Refer KB for details.

NOTE:

  • Local override only pertains to the portal itself.
  • Remote value gets pushed to data sources that use it (DA, NFA).