Authentication fails after resetting the "root" password of vCenter server configured in HA mode (VCHA)
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Authentication fails after resetting the "root" password of vCenter server configured in HA mode (VCHA)

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Article ID: 399040

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • VCHA is configured in the environment.
  • After resetting the root account password of vCenter Server Appliance on Passive node, vCenter server VAMI interface login might work, but when logging into the vCenter via SSH using the root user, authentication will fail.
  • Even after logging in using the old password, authentication will fail.

Environment

VMware vCenter Server 7.x

VMware vCenter server 8.x

Cause

If the "root" password reset is attempted on the VCHA Passive node, similar issue can encounter.

Resolution

 

To identify the Active Node in vCenter HA configuration:

 

Method 1: Validate the Active node from vSphere Client UI using vCenter HA configuration:

 

Method 2: The vCenter HA Active appliance will have 2 ethernet cards (eth0 and eth1) with IP addresses assigned:

 

Note: In case you are unable to reset the root user password in Active node (or root credentials not working), refer below steps to destroy and redeploy VCHA:

  1. Disable and destroy VCHA from the vSphere UI from ACTIVE node. Refer this documentation for detailed steps: Remove a vCenter HA Configuration

  2. Delete all old snapshots of the active vCenter VM.

  3. Reset the root password (if needed) using this KB article  Reset the root password in vCenter Server Appliance without reboot / 6.7u1 / 7.x / 8.x
  4. Validate the root credentials via SSH and VAMI pages and ensure successful authentication.

  5. Redeploy the Passive or Witness nodes using this KB: Redeploy Redeploy the Passive or Witness nodes