You suspend or take ownership of an alert in Aria Operations, but still receive emails about the same alert
It was thought that suspending an alert would stop all email notifications from being received
You don't want to disable the alert in the assigned policy as you need to ensure the issue in the alert gets resolved after some time
You want to be notified in email if the alert was not resolved, but not get too many unnecessary emails
Environment
Aria Operations 8.x
Cause
When the alert notification was defined in Configurations > Notifications, the 'Notify On' value was left at the default value of "All Statuses"
If your alert notification is set to notify on All Statuses, you get the initial email on the New alert, you also get a notification email after Suspending the alert as it considers this as an Update. During the suspend duration, you should not get another email notification for that same alert unless you suspended a Warning alert but then it becomes Critical and a new alert gets generated. Once the suspend duration time has passed, the alert Control State changes from 'Suspended' back to 'Open'. The system considers this a new Update and a new email notification is sent that states 'updated' in the Subject field.
Resolution
Ensure that you are setting the 'Notify On: Select the Alert status change you want to receive notification on' value to New only within the notification configuration
If you want to be immediately alerted if someone takes ownership or suspends an alert but the issue is not resolved, consider defining an additional notification rule to just look for control state to be 'Assigned or Suspended'.
Try adding a "delay to notify" which is the time to wait before sending an email if the alert has not been resolved once it's suspended or owned. The Owned control state would be more reliable for any follow up emails as the Suspend state will likely not persist.