Symantec VIP Enterprise Gateway 9.11.1 does not recover from Automatic Business Continuity mode
search cancel

Symantec VIP Enterprise Gateway 9.11.1 does not recover from Automatic Business Continuity mode

book

Article ID: 398947

calendar_today

Updated On:

Products

VIP Service

Issue/Introduction

The VIP Enterprise Gateway Validation Servers status in the console shows the status of being in Automatic Business Continuity mode while there is connectivity to the VIP Cloud. Restarting the Validation Server service(s) and the VIP Healthcheck Service does not reset the error. The Healthcheck.log contains the error:

DEBUG "2025-10-01 00:00:01.966 GMT+0000" 0.0.0.0 healthcheck 0 0 0  "text=Attempting to connect to the endpoint."
ERROR "2025-10-01 00:00:01.966 GMT+0000" 0.0.0.0 healthcheck 0 0 0  "text=Failed to read the file: null\conf\liveupdate.inv"
DEBUG "2025-10-01 00:00:01.966 GMT+0000" 0.0.0.0 healthcheck 0 0 0  "text=Other Exception : Cannot invoke \"String.split(String)\" because the return value of \"com.symantec.healthcheck.client.MultiStepAuthRestfulClient.getDetailedVersion()\" is null"
DEBUG "2025-10-01 00:00:01.966 GMT+0000" 0.0.0.0 healthcheck 0 0 0  "text=Detailed Error: java.lang.NullPointerException: Cannot invoke \"String.split(String)\" because the return value of \"com.symantec.healthcheck.client.MultiStepAuthRestfulClient.getDetailedVersion()\" is null"

Restarting the server resolves the issue but the same behavior may return.

Environment

Symantec VIP Enterprise Gateway 9.11.1

Cause

This can occur after an upgrade or migration due to a NullPointerException when attempting to connect to the endpoint userservices-auth.vip.symantec.com.

Resolution

Follow the steps below to resolve the Healthcheck Service startup issue:

1. Stop the Healthcheck Service

  • Open Services (services.msc).
  • Locate the Symantec VIP Healthcheck Service.

  • Stop the service. (If the service will not stop, set the status to DISABLED, click OK. Wait several seconds, then set the status to MANUAL.)

2. Modify the Healthcheck Configuration File

  • Navigate to the EG installation directory, typically:
    C:\Program Files\Symantec\VIP_Enterprise_Gateway\tools\

  • Create a backup of the file:
    healthcheckservice.xml

  • Open the original healthcheckservice.xml in a text editor (e.g., Notepad++) with administrative privileges.

  • Locate the following entry in the file:

    <argument>-jar</argument>
  • Insert the following line above that entry:

    <argument>-Dversionhome=C:\Program Files\Symantec\VIP_Enterprise_Gateway</argument>
     
    Note: If your Enterprise Gateway installation path is different, adjust the path accordingly to reflect the actual install location.

3. Restart the Healthcheck Service

  • Go back to Services.

  • Locate Symantec VIP Health Check Service and set the startup type to 'automatic'. Click OK.
  • Right-click on Symantec VIP Health Check Service and select Start.

Example:

Expected Result: The Healthcheck Service should start successfully and the Validation Server status will no longer shows as being in Automatic Business Continuity mode.