"You are currently impersonating" Toast twice when accessing a channel on a page
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"You are currently impersonating" Toast twice when accessing a channel on a page

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Article ID: 398807

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

When using the impersonation feature in Clarity, the message "You are currently impersonating" appears twice when accessing channels or embedded content.

STEPS TO REPRODUCE

  1. Go to MUX > Custom investments > Open any investment
       Note the URL:
       http://myClarityserver:8080/pm/#/investments/custLiveCusts/common
  2. MUX Administration > Blueprints > Make a copy of the Page blueprint
  3. On the blueprint, add a channel with the Custom investment URL
       http://myClarityserver:8080/pm/#/investments/custAacustinvs/common?puiFullscreen=on
  4. Go to MUX > Pages and create a page > My Custom Page and link it to the above blueprint
  5. MUX Administration > System settings > Navigation menu, add the page to the menu
  6. MUX Administration > System settings > Homepage > make the page available on the menu to anyone with the Basic group 
  7. Create a user and grant all access rights: Mytestuser
  8. Using the avatar on the top right hand side of the page, access the Impersonate a User feature
  9. Select the Mytestuser to be impersonated
  10. The custom home page we configured loads > Go to the Channel

Expected Results: You are currently impersonating Mytestuser, Mytestuser toast loads once
Actual Results: You are currently impersonating Mytestuser, Mytestuser toast loads twice

Environment

Clarity 16.3.1, 16.3.2

Cause

This is caused by DE170926

Resolution

This is working as expected.

The Channel is accessing a new user experience page and therefore, the page indicates that the data is coming from the account of the impersonated user.

The Channel configuration shows the entire page for which the Avatar sub-menu is available and hence impersonation message here as well