SDDC Manager UI fails to load with error "VMware Cloud Foundation is initializing"
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SDDC Manager UI fails to load with error "VMware Cloud Foundation is initializing"

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Article ID: 398796

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Updated On: 06-11-2025

Products

VMware SDDC Manager

Issue/Introduction

  • SDDC Manager UI fails to load with error - "VMware Cloud Foundation is initializing"

  • sddcManagerServer.log - /var/log/vmware/vcf/sddc-manager-ui-app/sddcManagerServer.log

2025-05-24T06:16:20.825+0000 WARN [4b9bad02fde646e1, 1522d6dccfb54fb4] [services/pscUtils.js, init-pscs, attemptPSCInitWithRetry:111]
100.109: VError: PSC Initilization attempt "4" failed: Failed to initiate PSC: Primary psc init failed and failover psc init also failed: Unable to retrieve iDP Metadata: Request failed with status code 500
    at Object.initializationPscError (/opt/vmware/vcf/sddc-manager-ui-app/server/src/errors/VCFError.js:104:5)
    at attemptPSCInitWithRetry (/opt/vmware/vcf/sddc-manager-ui-app/server/src/services/pscUtils.js:104:46)
    at process.processTicksAndRejections (node:internal/process/task_queues:95:5)
Error Info: {"retryCount":4,"status":403,"errorModule":100,"errorCode":109,"code":"ERR_BAD_RESPONSE"}

Environment

VMware Cloud Foundation 5.x

Cause

  • On boot, the SDDC tries to establish an SSH connection to the Management Domain vCenter.

  • SDDC Manager failed to access the Management Domain vCenter Server SSH, which may be caused by the reasons below:

    • SSH is deactivated on the Management Domain vCenter Server.

    • The root password on the Management Domain vCenter has expired

    • The root password has been changed on the Management Domain vCenter, the UI will not launch correctly as SDDC Manager is unaware of the new root password on the vCenter side and will continue to try to connect using the old password.

    • The root account of the vCenter is locked due to failed authentication attempts.

Resolution

  1. Stop the commonsvcs and sddc-manager-ui.service

    systemctl stop commonsvcs 
    systemctl stop sddc-manager-ui-app.service

  2. Take SSH session to vCenter 

  3. Reset the locked account count

    /usr/sbin/faillock --user root --reset

  4. Check the SSH access from SDDC to vCenter and retrieve the SSH host keys 

    ssh root@<vc-fqdn>
    ssh-keyscan -vvv <VC_FQDN>

  5. Start the commonsvcs and sddc-manager-ui.service 

    systemctl start commonsvcs 
    systemctl start sddc-manager-ui-app.service

Additional Information