Catalog offerings are not loading in Service Point after enabling SSL.
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Catalog offerings are not loading in Service Point after enabling SSL.

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Article ID: 398792

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Catalog

Issue/Introduction

After enabling SSL across the solution, the offerings stopped loading in the service point. When trying to click the offering, it doesn't load.

Environment

CA Service Desk Manager 17.4

Cause

We observed that cookie which was generated by countinfo or buistatus guinode calls to Catalog by sending X-AccessToken (In case of NTLM or SAML) or eiamArtifact( in case of basic authentication) was not used by the subsequent requests i.e request_create guinode.

Under cookies section of the developer tools, we see the following error:

"This cookie was blocked because the path was not an exact match for a superdirectory of the request url's path."

The cookie was generated for "/usm" path. However it is not used by the calls that are originating from Service Point.  This error will occur if there is a wrong path entry for Catalog URL in Service Desk under Administration → Options Manager → CA Service Catalog→ casc_endpoint .

Ex: "https://<catalogserver>:8443//usm/services"

If there is a double '/' in the url after the port, it will block the cookie (as part of request header) , as '/usm' doesn't match with '//usm'.

Resolution

Login to CA Service Desk

Go to  Administration → Options Manager → CA Service Catalog→ casc_endpoint

Update endpoint to the correct value"https://<catalogserver>:8443/usm/services"

Recycle SDM and XFlow services sequentially.