If a ticket is copied from an existing ticket which has description and once we enter new description the changes are lost on saving.
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If a ticket is copied from an existing ticket which has description and once we enter new description the changes are lost on saving.

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Article ID: 398791

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Updated On:

Products

CA Service Management - Service Desk Manager

Issue/Introduction

In the 17.4 RU4 ITIL content installed environment, the new description of the copied tickets are not saved.

  1. Create a request, and complete all fields as required, ensuring text is entered in the description field. 
  2. Save the request.
  3. Now either from file -> Copy or from the list form right click on any ticket and select copy , new window is opened with fields filled with original ticket.
  4. In the new ticket add new description and save. Once saved the description is lost.

Same behavior is noted with text entered with <> ex: <test>, the descripion will be empty. Enter the text as below:

Once the ticket is saved it is empty as below:

Environment

Service Desk Manager 17.4 RU4

Cause

The issue is happening because missing HTML description related changes in the ITIL content.

As part of 17.4RU <2,3,4> DVD, in the path CASM_17.4.<RU2,RU3,RU4>.0\filestore\ITILContent we are delivering updated htmpl files.

Resolution

To address this behavior please follow the steps as mentioned in the below tech doc:

https://techdocs.broadcom.com/us/en/ca-enterprise-software/business-management/ca-service-management/17-4/administering/rte-capability-in-ca-sdm.html

RTE for ITIL content
If CA SDM is integrated with ITIL content, RTE functionality does not work.
 
To enable RTE, follow the mentioned steps:
  • Login into the ITIL content installed machine after 17.4RU2 patch installed (BG server or Primary Server machine).
  • Stop the CA SDM services.
  • Take the backup of these files (detail_chg.htmpl,detail_cr.htmpl,detail_in.htmpl and detail_pr.htmpl) from <NX_ROOT>/site/mods/www/htmpl/web/analyst folder.
  • Take these files: (detail_chg.htmpl,detail_cr.htmpl,detail_in.htmpl and detail_pr.htmpl) from the extracted 17.4RU2 patch,
     /filestore/ITILcontent folder.
     
    Now compare the newly extracted files with your existing files and merge the changes if required. Copy the updated files into: 
    <NX_ROOT>/site/mods/www/htmpl/web/analyst
     folder
  • Start the CA SDM Services.
  • Repeat the steps 1-5 for All Standby servers, All Application Servers in case of AA environment.
  • Repeat the steps 1-5 for All Secondary Servers in case of Primary Secondary environment.