PAM Client Cannot Launch With Other JDK Installed
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PAM Client Cannot Launch With Other JDK Installed

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Article ID: 398751

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Updated On:

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

When another JDK is installed on a user's workstation, the PAM client fails to launch with the following error.

Error invoking main method

Cause

The other JDK installed on the workstation had the Java Access Bridge (JAB) enabled, causing the following error to appear in the logs.log file located in the base PAM Client directory.

2025-01-01 12:00:00 INFO  - java.lang.UnsatisfiedLinkError: C:\Users\<username>\CA PAM Client\runtime-17.0.7_7\bin\javaaccessbridge.dll: Can't find dependent libraries     syserr.write [main]

Resolution

The issue is resolved as 33564431/DE581098 in the 4.1.6 release, as listed in the Resolved Issues in 4.1.6. If an upgrade cannot be performed at this time, the following command can be used as a workaround.

> C:\Program Files (x86)\CA PAM Client\runtime-17.0.7_7\bin\jabswitch.exe -disable