Web UI stays stuck on 'Loading...' after upgrading to Usage Meter 9.0
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Web UI stays stuck on 'Loading...' after upgrading to Usage Meter 9.0

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Article ID: 398695

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Updated On:

Products

VMware Usage Meter

Issue/Introduction

Upgrading to VCF Usage Meter leads to the Web UI stuck on 'Loading...' after entering the username and password

 

Environment

VCF Usage Meter 9.0 

Cause

The Common Name (CN) on the UM SSL certificate does not match with the hostname on the appliance. 

Note: You can check the CN on the certificate from the browser by clicking on the lock icon next to the URL, opening the Certificate and going to the Details. 
          To check the hostname on the appliance, run: cat /etc/hostname

Resolution

Renew the SSL certificate on the Usage Meter as per this document

Additional Information

Before renewing the certificates check the FIPS status to choose the appropriate section from this document.
SSH to the Usage Meter and run the below command as usagemeter user.
Check the FIPS status

fips-util.sh -s | jq

Additionally, you can verify in the file below file, FIPS=1 indicates that it is enabled.

/boot/grub/grub.cfg

 

If the UI fails to load after renewing the certificate, please check the ownership on the keystore file located at /opt/vmware/cloudusagemetering/platform/security. The ownership for keystore needs to be usagemeter:usagemeter. 

If you see root:root, please update it by running:  

chown usagemeter:usagemeter /opt/vmware/cloudusagemetering/platform/security/keystore 

If the UI still fails to load after performing the steps above, kindly check whether the hostname and IP address of Usage Meter Virtual Machine are present in the /etc/hosts file of the Usage Meter VM

If not already present, please add the entries manually in the following format:

<IP Address> <Fully Qualified Domain Name>

This ensures proper name resolution, which is required for the UI to load correctly.