vSAN -- "vsan-healthcheck-disposable*" VMs created across Infrastructure and are not automatically removed after vSAN Test
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vSAN -- "vsan-healthcheck-disposable*" VMs created across Infrastructure and are not automatically removed after vSAN Test

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Article ID: 398693

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Updated On:

Products

VMware vSAN VMware vSAN 7.x VMware vSAN 8.x

Issue/Introduction

VMs with their names containing "vsan-healthcheck-disposable*" are being automatically created & deleted by the System,
when manually triggering the "VM Creation Test"
which can be found in the vSphere Web Client --> vSAN Cluster --> Monitor --> vSAN --> VM Creation Test
 

 

 
While this Test was not manually triggered, VMs with their names containing "vsan-healthcheck-disposable*" are being found in the vSphere Web Client,
while not being automatically deleted by the System.
 

 

 

 

 

 

Environment

vSAN 7.x
vSAN 8.x
 
 

Cause

The creation of these "vsan-healthcheck-disposable*" VMs was triggered by a custom script, Monitoring Tool and/or 3rd Party Product,
using a timeout value which is too small to complete the VM creation task. 
 
Result:
Despite the VM being created, the task internally timed out.
As a result the System is unable to follow up on the task, resulting in the fact that the "vsan-healthcheck-disposable*" VM is not being deleted by the System.
 

Resolution

A.) The "vsan-healthcheck-disposable*" VMs can be deleted manually without any risk by right-clicking the VM --> Delete from Disk
 
B.) The custom script, Monitoring Tool and/or 3rd Party Product which triggers the automatic generation of "vsan-healthcheck-disposable*" VMs
needs to be adjusted by increasing the programmed Timeout value to 2 minutes.
 
In the case that a custom PowerShell script is used, based on official PowerCLI module and command : "Get-VsanView"
Please change the Timeout X mentioned in this line:
$result = $vchs.VsanQueryVcClusterHealthSummary($VsanCluster.Id, X, $null, $true, $null, $fromCache, 
 
to this:
$result = $vchs.VsanQueryVcClusterHealthSummary($VsanCluster.Id, 120, $null, $true, $null, $fromCache,  
 
 
 
If assistance is required, please open a Ticket with VMware by Broadcom Support.

Additional Information

For VxRail Environments please see Dell/EMC KB.