Deleted Segments show "In progress" in NSX UI
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Deleted Segments show "In progress" in NSX UI

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Article ID: 398692

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Updated On:

Products

VMware NSX

Issue/Introduction

  • When attempting to delete segments from the Global Manager in a VMware NSX environment, the segments appear greyed out in the UI.
  • Segment status changes to *In Progress*, and the segments are not removed as expected.




Environment

VMware NSX

Cause

  • This issue occurs when a NSX segment is deleted from the Global Manager while a port or interface is still in use. The UI may display a port/interface count of (1), indicating that the interface is still attached.

Resolution

1. Navigate to the T0/T1 gateway of the Local Manager (LM) associated with the segment.
2. Identify the interface that is connected to segment being deleted
3. Click the three-dot menu (•••) next to the interface and select Revert to restore the GM config of the interface.


4. Return to the LM's Segments view and confirm that the port/interface count has changed from 1 to 0.
5. If the Global Manager (GM) still has not removed the segment, open an SSH session to the Local NSX Manager and run the following command to trigger a resynchronization:
   start search resync all
6. After the resync completes, the deletion pending segment should be automatically removed from the NSX UI.


 

Additional Information

Ensure that there are no active dependencies or services using the segment before attempting deletion. This process is applicable only in environments using Global Manager in NSX-T Federation deployments.