Operations Manager UI does not show any deployment progress after clicking "Show Progress"
search cancel

Operations Manager UI does not show any deployment progress after clicking "Show Progress"

book

Article ID: 398627

calendar_today

Updated On:

Products

Operations Manager

Issue/Introduction

During "Apply Change" on Ops Manager version 3.0.41, when you click "Show Progress" button it does not display change or progress of the current deployment

You see similar to screenshot below where it is stuck at 0% and does not progress

but when you use "Review Changes" then "Apply Change", you can see that it is progressing. 

 

So this means at the background there is no issue with the deployment. Alternatively you can also use bosh task or bosh tasks to verify deployment progress. Only the Ops manager UI "Show Progress" is affected.

 

 

Environment

Ops Manager v3.0.41

Cause

This is caused by a bug in Ops Manager v3.0.41 where in some cases, if one hits the "Show Progress" button from the "Applying Changes" page, the page will not load any content and one sees just the "blank" progress bar and an otherwise empty page.

 

Resolution

If you are unable to upgrade Ops Manager, here are some workaround that you can use:

  • Use commands such as
    bosh task
    bosh tasks
    bosh task <id>

    to monitor progress of the deployment

 

  • If using automation tools to deploy such as concourse, use the concourse logs to monitor the deployment
  • In some cases, let the same page where it is showing no progress to be open and wait. There will be no progress at the start but towards the end of the deployment the progress will become visible.  
  • Wait for a few minutes for a page to load. During testing it was observed is that if one waits a sufficient amount of time, the page should load as it is waiting for a log update before re-rendering.

Additional Information

A fix will be included in a future release of Ops Manager.