Add Scanner wizard returns "The proxy server setting has reported a timeout error. Please check the proxy settings."
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Add Scanner wizard returns "The proxy server setting has reported a timeout error. Please check the proxy settings."

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Article ID: 398615

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Updated On:

Products

Messaging Gateway

Issue/Introduction

When attempting to register the license for a new Messaging Gateway (SMG) scanner and using a proxy server, the Add Scanner Wizard spins for a few minutes and then returns an error indicating that the connection to the proxy server timed out.

The proxy server setting has reported a timeout error. Please check the proxy settings.

Cause

The scanner cannot connect to the IP address and port configured for the proxy server.

Resolution

This issue is usually due to entering an incorrect IP address or hostname for the proxy server.

  1. Confirm that the configured IP address and port are correct 
  2. Using the Utilities button on the Add Scanner Wizard page use ping to confirm that the proxy server is reachable
    Example: ping proxy.smg.test
  3. If the proxy server responds to pings, check whether the scanner can connect to the proxy server port via telnet
    1. Log into the scanner command line as admin
    2. Run telnet [proxy_ip] [proxy_port]
      Example:

scanner [10.8.0-7]> telnet proxy.smg.test 3128
Trying 10.0.0.80...
telnet: connect to address 10.0.0.80: Connection timed out

If the proxy server can be pinged but connection attempts via telnet time out, there is very likely a firewall preventing the scanner from connecting to the proxy server.