Data Solution instances with RabbitMQ solution are stuck in 'Pending' state.
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Data Solution instances with RabbitMQ solution are stuck in 'Pending' state.

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Article ID: 398548

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • Installing RabbitMQ solution is stuck in 'Pending' state.
  • While trying to check the status for the packages using the below commands, RabbitMQ packages says as 'Reconcile failed'
    kubectl get pkgr -n vcd-ds-system
    kubectl get pkgi -n vcd-ds-system 
  • The process fails while trying to fetch the resources and the error 'Reconcile failed: Fetching resources: Error (see .status.usefulErrorMessage for details)' is encountered while trying to check the status of the tanzu-rabbitmq-operator using the command kubectl get pkgr -n vcd-ds-system                                                                                                                                                                                     
  • While trying to check the detail info for pkgr tanzu-rabbitmq-operator using the command: kubectl -n vcd-ds-system get pkgr tanzu-rabbitmq-operator -oyaml , "Bad Credentials" error is thrown.

Environment

VMware Cloud Director 10.5.1.1

Container Service Extension 4.2.1

Data Solutions Extension 1.6

Cause

If the account credentials used for managing rabbitmq-kubernetes.packages.broadcom.com container registry does not have the required entitlements to access VMware Tanzu RabbitMQ on Kubernetes, then creation of RabbitMQ solutions fails while searching for the resources.

Resolution

  • Login to Broadcom support portal and access VMware Tanzu RabbitMQ on Kubernetes
  • If the files are not present as above, it means that the account does not have the required SKUs to download the resources.
  • The account with correct credentials will have access to the files like below:

To get the access to the VMware Tanzu RabbitMQ on Kubernetes files, please reach out to your Accounts team or raise a Non-Technical Support ticket with GCA team.