"IBM validation failed" error message in the Broadcom SCRT Report Management site
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"IBM validation failed" error message in the Broadcom SCRT Report Management site

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Article ID: 398543

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Updated On:

Products

Common Components and Services for z/OS

Issue/Introduction

When working in the 3270 Emulator with Code Pages different from IBM-037 (US) or IBM-500 (International) to run the CAISCRT Job, there could be several issues during the file transfer of the ISV SCRT Report file to the Broadcom SCRT Report Management site that deals with validation error messages.

This is the most frequent error message: 

>>>
IBM validation failed. See the Frequently Asked Questions in the online help.
<<<

Cause

The issue is related to character encoding and the @ symbol, which appears in the 'Contact_EMail' parameter in the input //PARMS DD.  
  

* ENTER THE EMAIL ADDRESS OF PERSON SUBMITTING THE REPORT
[email protected]    

Resolution

The first thing to attempt to fix the "IBM validation failed" error message in the Broadcom SCRT Report Management site is to update the CAISCRT JCL in the following way to remove the @ symbol. 

* ENTER THE EMAIL ADDRESS OF PERSON SUBMITTING THE REPORT
[email protected]                  
 
to
 
* ENTER THE EMAIL ADDRESS OF PERSON SUBMITTING THE REPORT
Contact_EMail=User.Name_at_company-name.com 


Then run again the CAISCRT Job to create a new ISV SCRT Report. 
  
However this change will not fix all the "IBM validation failed" error messages that can be raised, so if any additional error message is found in the Broadcom SCRT Report Management site, please do not hesitate to open a Case in the Broadcom Support portal with the Common Services product and the Common Services support team can assist you updating the CAISCRT JCL with the appropriate statements.