Publishing fails for Generator names greater than 50 characters : "String or binary data would be truncated in table gtrep.dbo.gtrep_publish_job_info"
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Publishing fails for Generator names greater than 50 characters : "String or binary data would be truncated in table gtrep.dbo.gtrep_publish_job_info"

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Article ID: 398451

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Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

When trying to publish a new generator we are receiving the following error.

 

Environment

TDM 4.11

Cause

Customer has Generator Names longer than 50 characters.  

Resolution

Applying patch TDMWeb-4.11.2009.0.zip and later resolves this issue.

Additional Information

Steps to apply patch:

The TDMWeb patch contains a full rebuild install of the TDM Portal application. Running the installer will preform an upgrade to TDM Portal.

Note: The first time the CA Test Data Manager Portal service starts up, and connects to the gtrep repository database, TDM check the schema version of the gtrep database. If the gtrep schema version is older than what is available from the patch, the gtrep schema is upgraded. Therefore, upgrading your TDM Portal version, may also upgrade your gtrep database schema.

  1. Have your DBA make a full backup of the gtrep database.

  2. Make sure everyone has logged off the TDM Portal application, and close the browser.

  3. Stop the CA Test Data Manager Portal Service.

  4. Stop the OrientDB Service.

  5. Take a backup copy of the following TDM Portal installation directories: By default, this is located at C:\Program Files\CA\CA Test Data Manager Portal.
    • C:\Program Files\CA\CA Test Data Manager Portal (at minimum make a copy of the conf and orientdb subdirectories)
    • %ProgramData%\CA\CA Test Data Manager Portal (at minimum make a copy of the orientdb subdirectory)

  6. Open a Windows File Explorer and navigate to %ProgramData%\CA\CA Test Data Manager Portal\logs and delete all the files. This will ensure we have a fresh, clean set of logs to review in case there are any issues.

  7. Extract the TDMWeb-4.11.2009.0.zip file in a temporary directory of your choice.

  8. As Administrator, double-click on the setup_ CA Test Data Manager Portal4.11.2009.0.exe file to start the installation wizard.

  9. Follow the steps in the installation executable to upgrade the Portal.

  10. Re-start the Portal services. They should restart automatically, but it would be good to verify. If the services did not restart automatically, first restart the OrientDB service, then restart the CA Test Data Manager Portal service.

    Note: By default, the CA Test Data Manager Portal service is configured to start under the Local System Account. If your implementation of the "CA Test Data Manager Portal" Windows service should be running under a service account, you will need to:
    1. Stop the CA Test Data Manager Portal service
    2. Right-click on the CA Test Data Manager Portal service, and select Properties
    3. In the Properties dialog window, select the Log On tab
    4. Modify the properties to run the service under the appropriate service account
    5. Select OK, and close the dialog window.
    6. Restart the CA Test Data Manager Portal service.


  11. Open the Web browser and clear the browser cache.

  12. It may take several minutes for the TDM microservices to fully restart. You can monitor this by opening Task Manager and watch the CPU utilization of the machine. While the microservices are starting, you will see the CPU very high. Once the CPU utilization returns to normal, you can re-launch the Portal Page.

  13. Log into Portal and verify that the upgraded version is displayed in the lower left.

  14. Re-test issue.