FC Storage -- After attempting to unmount Datastore: Unable to do any vMotions from the ESXi Host / Host is not responding to any actions
search cancel

FC Storage -- After attempting to unmount Datastore: Unable to do any vMotions from the ESXi Host / Host is not responding to any actions

book

Article ID: 398429

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

One or more of the following Symptoms apply, after the Datastore was attempted to unmount but task timed out:

 

  • Host went into a non-responding state and had to be rebooted

  • Web Client: Host --> Tab "Configure" --> Storage Devices: The backing Storage device is still showing as "Attached":

 

  • Via the The Host Client (  http://esxi-3.example.com/ui  ) it is observed that the Datastore is still showing up but with 0 Byte and missing option "unmount" from the context menu.

 

 

 

Environment

ESXi (All Versions)

Cause

vSphere still sees the Datastore as being presented.
This is typically caused due to the LUN being unmapped from the Host from the array side before unmounting the Datastore from vCenter first.
 

Resolution

1.) Put Host in Maintenance Mode and reboot it (if not already done)
2.) If the issue persists after reboot, reach out to your Storage Team/Vendor to have the LUN/Volume checked on whether it is still mapped
3.) If it is still mapped: Have the Storage Team/Vendor unmap the LUN/Volume from the Array
4.) Perform Storage Rescan on Host and Cluster Level (= if Cluster exists) 
5.) Evaluate whether the Datastore is still showing as described in the section "Issue/Introduction"