File Attachment Issue with Special Characters
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File Attachment Issue with Special Characters

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Article ID: 398405

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Updated On:

Products

CA Service Catalog

Issue/Introduction

During the creation of a new ticket from Service Catalog, an end user uploaded a file containing a long-dash (ascii code 150) rather than a short-dash (ascii code 45).  

The file attachment upload interface allowed it and the user was able to submit the request.  The file was subsequently blocked and dropped.  

When the user went in after the request was created and used the file attachment upload interface, a pop-up came up with the error message "The file name you have entered is not valid.  Please enter a valid file name."

Environment

CA Service Catalog 17.x

All Supported Operating Systems

Cause

The %USM_HOME%\view\conf\ESAPI.properties file contains configuration information which govern the behavior of CA Service Catalog attachments.

Resolution

The ESAPI.properties file was missing the opening square bracket.

Incorrect syntax:

Validator.FileName=^a-zA-Z0-9\\w\\p{L}!@#$%^&{}\\[\\_+\\-=,.~'` \u2013]{1,255}$

Correct syntax:

Validator.FileName=^[a-zA-Z0-9\\w\\p{L}!@#$%^&{}\\[\\_+\\-=,.~'` \u2013]{1,255}$

After making any changes to the ESAPI.properties file, a restart of the CA Service Catalog service is required.

Additional Information