ESXi vLCM upgrade fails with "Solution with ID com.vmware.vsphere-ha_XXX is not found in the collection"
search cancel

ESXi vLCM upgrade fails with "Solution with ID com.vmware.vsphere-ha_XXX is not found in the collection"

book

Article ID: 398377

calendar_today

Updated On:

Products

VMware vSphere ESXi VMware vCenter Server

Issue/Introduction

Where the value of the bootstate in the boot.cfg file is 4, and the var/db/esximg/solutions/ folder is empty in the imgdb.tgz file on the host, this can cause vLCM to not be able to identify the vSphere HA version present on the host and thus not remediate the host correctly.

Incorrect boot.cfg entry:

[root@] cat altbootbank/boot.cfg
bootstate=4   <=== this is incorrect

Empty solutions folder:

[root@] tar -xvf altbootbank/imgdb.tgz
...
var/db/esximg/solutions/
...
[root@] ls altbootbank/var/db/esximg/solutions/
[root@]

 

In /var/run/log/lifecycle.log we see the following entry:

2025-01-01T01:01:01.001Z lifecycle: XXX: HostImage:XXX INFO Installer <class 'vmware.esximage.Installer.BootBankInstaller.BootBankInstaller'> was not initiated - reason: 'Solution with ID com.vmware.vsphere-ha_7.0.3-24321951 is not found in the collection'

Cause

The cause is currently unknown.

Resolution

1. Take a backup of the altbootbank..
2. Clear all the contents of the altbootbank
3. Create a fresh boot.cfg file in the altbootbank with the following content.
[root@] cat altbootbank/boot.cfg
bootstate=3
title=
timeout=5
prefix=
kernel=
kernelopt=
modules=
build=
updated=0

4. Perform the remediation, it should pick the bootbank db while initializing the image profile for bootbank installer.