Unable to login vCenter Server after replacing ADFS server root certificate
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Unable to login vCenter Server after replacing ADFS server root certificate

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Article ID: 398323

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • ADFS server root certificate has been replaced recently.
  • The new certificate has been added to vCenter Server Trusted Root Certificates Store.
  • Attempting to login to vCenter Server using ADFS fails and login process is stuck on the authentication page.

Environment

VMware vCenter Server 7.x

VMware vCenter Server 8.x

Cause

This is because vCenter is not trusting the new certificate.

Resolution

  • Restart vCenter Server services or reboot vCenter Server Appliance to reload the new certificate.
    • Run the following command on vCenter Server to restart services:  service-control –-stop –-all && service-control –-start --all
  • If these steps do not resolve the issue, contact Broadcom Support for further assistance.