When trying to set up IPMI on an ESXi host to enable Distributed Power Management (DPM), we are unable to do so, despite being able to successfully set up IPMI on a different ESXi host
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When trying to set up IPMI on an ESXi host to enable Distributed Power Management (DPM), we are unable to do so, despite being able to successfully set up IPMI on a different ESXi host

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Article ID: 398297

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Updated On:

Products

VMware vCenter Server VMware vSphere ESXi

Issue/Introduction

By way of troubleshooting in a situation like this, the first step is to compare all settings in BIOS and other vendor-tunable settings between the successful ESXi host and the problematic ESXi host.

There are specific hardware requirements associated with ESXi hosts to enable this power consumption reduction strategy. 

As mentioned in VMware vSphere - Managing Power Resources vCenter can potentially reduce the power consumption within a DRS (Distributed Resource Scheduler) cluster, by powering hosts on and off based on cluster resource utilization.

 

 

 

 

Cause

vSphere DPM can use one of three power management protocols to bring a host out of standby mode:

  • Intelligent Platform Management Interface (IPMI),
  • Hewlett-Packard Integrated Lights-Out (iLO), or
  • Wake-On-LAN (WOL).

Each protocol requires its own hardware support and configuration.

If a host does not support any of these protocols it cannot be put into standby mode by vSphere DPM.

If a host supports multiple protocols, they are used in the following order: IPMI, iLO, WOL.

If you can achieve success in setting up IPMI with one ESXi host, yet have an issue with a second ESXi host, and both ESXi hosts are the same hardware configuration (and have exactly the same BIOS and other vendor-tunable settings), then a case should be opened with the hardware vendor to further troubleshoot.  

 

Resolution

The process to configure ESXi hosts to enable this functionality is described in VMware vSphere - Configure IPMI or iLO Settings for vSphere DPM

Review the requirements in the "Before you begin" section and confirm that your hardware is able to support at least one of the required "wake" protocols.  

See your hardware vendor’s server documentation for more information. 

That documentation should explain steps that need to be performed before following the steps using the vSphere client, as explained in  VMware vSphere - Configure IPMI or iLO Settings for vSphere DPM

If you have followed the suggestions in this KB and the documentation, and have opened a case with the hardware vendor, please open a case with Broadcom Support and supply the following:

  1. The name of the ESXi host where you have successfully set up IPMI; and
  2. The name of the ESXi host where you have not been able to set up IPMI; and
  3. Support bundles for each of the two ESXi hosts indicated above; and
  4. The case number for the case you have opened with the hardware vendor; and
  5. Screen shots showing what you have done, and the results, for each of the successful and unsuccessful cases. 

It may be necessary to have a collaborative call with Broadcom and the hardware vendor support troubleshooting together.