Error: “VssSyncStart operation failed” while taking a quiesce snapshot
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Error: “VssSyncStart operation failed” while taking a quiesce snapshot

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Article ID: 398269

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

When quiescing a guest operating system using the Microsoft Volume Shadow Copy Service (VSS) prior to a snapshot, the operation fails. Following the failure, running the following command "vssadmin list writers" from the command prompt of the VM shows an error message to the 'System Writer' of "Inconsistent shadow copy".

Environment

  • VMware vSphere ESXi 6.x
  • VMware vSphere ESXi 7.x
  • VMware vSphere ESXi 8.x

Cause

  • The guest OS reports an error during quiescing. This suggests a problem within the guest OS itself.
  • Running command "vssadmin list shadows" return with a message of how shadow copies.
  • The vmfs/volumes/<datastore-UUID>/vmware.log shows a message of "VssSyncStart operation failed"
    YYYY-MM-DDTXX:XX:XX.XXXX In(05) vmx - [msg.snapshot.quiesce.vmerr] The guest OS has reported an error during quiescing.
    YYYY-MM-DDTXX:XX:XX.XXXX In(05)+ vmx - The error code was: 5
    YYYY-MM-DDTXX:XX:XX.XXXX In(05)+ vmx - The error message was: 'VssSyncStart' operation failed: IDispatch error #8449 (0x80042301)
    
  • The same issue happens when doing a manual quiesce snapshot from the vCenter and ESXi UI and 3rd party backup applications.

Resolution

Engage Microsoft support to ensure that there are no known issues with VSS. Visit http://support.microsoft.com/ to see if there are any patches and updates for VSS.

Additional Information